Chapa
Hi we are having trouble getting the motors to turn both directions with the joystick. The motors are capable of moving in both directions, which was confirmed by switching the red and black cables. What is happening is when we connect the motor to port 2, the channel 1/2 jjoystick is supposed to move motor one direction when pushing stick up and the other when pushing the stick down, but we can only get it to turn one direction when pushing the joystick up it rotates the motor. When pushing it down it does nothing. When we push the joystick right again it rotates the same direction, but left nothing happens. We are using the default code. We have tried the following:
1. We updated firmware
2. We tried both simulink and easy c default code.
3. We tried different motors.
4. We tried different wires .
5. We tried a new cortex and joystick.
6. We re calibrated the joystick.

Any help appreciated.
Quote 0 0
jgraber
See the Simulink forum for longer description.   It sounds like you have a half-bad MC#29 motor controller between the cortex and the motor.  
You did not say you already tried this, so it is the likely problem.
You also said "motors"  as if more than one motor were doing this, please confirm?

If the problem is only the port2 motor, but not the port9,
try swapping the wires between port9 and port2;
  If the problem is now on port9,  then it is following the MC#29 currently plugged into port9, and the MC#29 is half-bad.  Ask your hub for a replacement, or buy one, or use one from a Vex robot you have sitting around.
Quote 0 0
Chapa
Thanks!
Quote 0 0